Windows 7: DNS-Problem beim Domänenbeitritt

Von Stefan | Unter Active Directory, IT, Schul-IT, Top Ten, Windows, Windows 7 | 52 Kommentare  | 117114 Hits.
TOP del.icio.us digg

117115 mal gelesen

Microsoft überrascht immer wieder:  Bei uns läuft ein Windows 2008 Server als Domain Controller mit Active Directory. In diese Domäne möchte ich einen Windows 7-Rechner aufnehmen. Alles Standard, alles kein Problem – sollte man meinen, bis diese Meldung erscheint:

„Fehler beim Versuch, den DNS-Namen eines Domänencontrollers in der Domäne … aufzulösen“

Nach langer Recherche im Netz stellt sich heraus, dass in der Registry des frischinstallierten Rechners zwei Schlüssel fehlen. 🙁

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000

Und siehe da: Beitritt gelingt ohne Probleme. 🙂 Dank an Slarti für die Lösung!

52 Comments

  1. Comment by Sebastian:

    Vielen Dank für diese Lösung, habe lange nach gesucht und hat auf Anhieb funktioniert! Perfekt, Danke

  2. Comment by Stephan:

    Hey hey!

    VIELEN DANK für die Lösung auch von mir.
    Bei mir wars aber keine frische Win7 sondern die lief schon in einer Domäne:
    Win7 Pro war in einer Domäne.
    Neuen Server aufgesetzt mit neuem Domänennamen.
    Bei dem Win7 PC kam dann die Meldung!

    Jetzt läufts!
    Danke danke,

    Stephano

  3. Comment by Sunnyboyx:

    Klasse bei mir hats auch funktioniert. Supergeil. Du bist Spitze !! :-))

  4. Comment by Oliver Stadler:

    Herzlichen Dank, das hat prima funktioniert, toller Tip!!

  5. Comment by Patrick:

    nach 5 std. auch auf die Seite hier gekommen. Tausend Dank!
    Brachte weder Server 2008 noch Win7 Client in die Domäne.
    nach dem regedit plopp.. beide drin… DANKE!

  6. Comment by Marvin:

    Super! Super! Super! Vielen Dank, hat mir sehr geholfen!

  7. Comment by Jonas:

    danke, danke, superfunktioniert, uff!

  8. Comment by Rafael:

    Hallo,

    das ist ein super Tip gewesen, vielen Dank.

    br
    ruffy

  9. Comment by Manuel:

    Hallo,

    auch von mir vielen Dank. Sieht man wieder was Microsoft für einen Mist raus bringt, wenn zwei Schlüssel fehlen, um der Domäne beizutreten. Das sollte Microsoft eigentlich schon so einbauen, dass es automatisch funktioniert. Das Problem ist ja schon länger anscheinend bekannt, aber selbst bei Windows 8 funktioniert es nicht ohne die zwei Schlüssel hinzuzufügen.

  10. Comment by Juergen:

    Vielen Dank! Unglaublich, was MS da produziert.

  11. Comment by mike:

    Danke!

  12. Comment by mel:

    Danke! Das hat mich zeitlich echt gerettet!!!

  13. Comment by juergen k.:

    Danke!!!!

    Ohne Deine Lösung hätte ich aufgeben müssen. Hat sofort funktioniert

  14. Comment by Fabian:

    Danke!!!!!

  15. Comment by BoJustus:

    Auf welchem PC muss ich das im RegEdit ändern? Auf dem normalen Win 7 PC oder auf dem Server?? Auf beiden PCs gibt es kein DomainCompatibilityMode und DNSNameResolutionRequired!

  16. Comment by Thomas:

    Hallo und schönen Gruß!

    ich habe einen WIN7 Pro PC neu installiert und komme nicht in die Domäne. Ich mach da höchstwahrscheinlich einen Fehler beim Erstellen des Schlüsseleintrags. Könnte mir jemand bitte genaue Anweisungen geben. Ich komme bis zur Liste und darin habe ich zwei neue reg_dword einträge erstellt. Ich komme aber nicht weiter, und der PC geht nicht in die Domäne……

    Danke!

    • Stefan
      Comment by Stefan:

      Hallo Thomas und einen herzlichen Gruß nach Südtirol, wo ich gerne Urlaub mache,

      am besten erstellst Du eine Textdatei mit dem Notepad, der Du die Dateierweiterung .reg gibst. Dort kopierst Du einfach den genannten Text hinein. Doppelklick auf die Datei, und die Schlüssel sind eingetragen. Dann sollte auch der Domänenbeitritt klappen. Ansonsten hier einfach nochmal die genaue Fehlermeldung posten!

      Gruß, Stefan

  17. Comment by ftelch:

    Hallo Stefan,

    Deine Anleitung war die Rettung vor einer langen Computernacht….

    Vielen Dank! Es funktioniert…

    Beste Grüße

  18. Comment by Thomas:

    Vielen Dank. Hat mir sehr geholfen!

  19. Comment by Torsten:

    Vielen Dank, nach 6 Stunden vergeblicher DNS und DHCP Konfiguriererei lag es letzendlich an diesen beiden Schlüßeln.
    Tausend dank!!!

  20. Comment by Michael B.:

    Super Tip. Danke! Diverse Rechner bisher ohne probleme in die Domain, der eine jetzt nur mit dieser Änderung in der REG….

  21. Comment by Martin B.:

    Vielen vielen Dank!

    Unglaublich, dass so ein Fehler überhaupt möglich ist!

    Und ich forste das Technet Rauf und Runter ab ….

  22. Comment by Michael Hummel:

    Super – hat mich viel Nerven gekostet.
    Bin von einer Domäne in eine andere Umgezogen und habe am Rechner entsprechend die Domänenzuhörigkeit ändern wollen…

    Klappte 🙂 bin happy

    LG Michael

  23. Comment by Christoph Ehrke:

    Super. Vielen Dank. Ich habe nur eine Stunde vergeblich den Fehler gesucht und dann erst gegoogelt. Man zweifelt schnell an seiner Kompetenz, wenn man einen Domain Join machen will und keinen Fehler findet ;). Bei mir war es auch ein komplett neuer PC. Evtl. sind die Win7Pro Images der Distributoren nicht sauber. Pure Mutmaßung.

  24. Comment by Robin:

    Danke

  25. Comment by Marxelus:

    Hi Zusammen,

    Ich bin neu hier.

    Ich versuche seit 2 Tage eine Win 7 32bit vers VM mit ein Win Server 2008 R2 VM( ich nutze Oracle Virtual Box) in eine Domäne zu verbinden.

    Die Netzwerkeinstellungen für die beides VM:

    Adapter 1: NAT, Adapter 2 Netzwekbrücke

    Wenn ich möchte ein user von Win 7 in die Domäne einloggen bekomme ich immer diese Fehler:

    Fehler beim versuch,den DNS Namen eines Domänecontrollers in der Domäne aufzulösen……..
    Ich habe versucht mit den registry etwas zu ändern aber bekomme ich diese fehler:datei.reg kann nicht importiert werden:Die angegebene datei ist keine regiesterungsdatei

    Was mache ich falsch?

    Bitte hilfe…

    Grüße,

    Marcel

  26. Comment by Bruno:

    Vielen Dank! Bei mir wars auch ein Win7 der aber schon seit Jahren läuft. Ich hab auch nur kurz gesucht zum Glück, es kommt aber vermutlich bei Google immer weiter oben =) Genial!! Vorallem der Tipp es in die Datei zu kopieren, denn beim manuellen eintragen hat es zuerst auch nicht geklappt…

  27. Comment by Psycho24:

    genial , hat nicht nur bei der win prof Version auf anhieb funktioniert sondern auch bei der Testversion von Windows 10 in der VB. Vielen Dank :).

  28. Comment by Josma:

    Hi Stefan!

    Hat auch bei mir funktioniert. Problem trat ebenfalls bei einem frisch installierten Win7 Pro auf.

    Ich bin zwar froh, das es jetzt funktioniert, aber was genau bewirken diese beiden Werte eigentlich?
    Ich habe mir auch dein ursprüngliches Post von Slarti durchgelesen, aber da scheint es ja um Samba zu gehen…

    Vielen Dank jedenfalls!
    Problem ist somit mal gelöst…

    • Stefan
      Comment by Stefan:

      Hi Josma,

      was die Werte genau machen, kann ich auch nur erahnen:
      „DomainCompatibilityMode“=dword:00000001 scheint wohl eine bestimmte Kompatibilitätsstufe der Domäne anzufordern (??)
      „DNSNameResolutionRequired“=dword:00000000 = schaltet wohl die Anforderung aus, dass der Rechnername per DNS aufgelöst werden muss.
      Egal, Hauptsache läuft 😉
      Gruß, Stefan

  29. Comment by Philip:

    Hallo,

    ich habe das selbe Problem.
    Leider bin ich ein totaler Laie.
    Könnt ihr mir sagen, wie ich den Schlüssel anlegen muss?
    Muss D-Word-Wert nehmen und als Wert 00000000 bzw. 00000001 eingeben?
    Wenn ja, welchen Namen muss ich dem Wert dann geben?

    Vielen Dank für die Hilfe!

  30. Comment by Pimky:

    Der Tipp hat mich eben vor einer sehr langen Nacht bewahrt.
    Tausend Dank für die Hilfe!

  31. Comment by DarkRedBull:

    Super danke, hat mich gerettet

  32. Comment by fz:

    Hat jemand eine Idee für Windows Server 2012 r2 ???

  33. Comment by DocSommer:

    Hallo zusammen,

    zunächst mal eine tolle Lösung. Habe allerdings W10 Clients und „nur“ einen W2003 Server. Hier fehlen ebenfalls die Schlüssel in der Regestry. Doch leider hat die Lösung hier nicht ganz geklappt.
    Anhebung in die Domäne hat funktioniert, doch nach dem Jubel mußte ich dann feststellen das der Rechner grotten Langsam wurde. Ich vermute das hier durch MS mit absicht nicht gewollt ist das die Kombi mit dem „veraltetem“ Server funktioniert.
    Hat irgendjemand evtl. eine Lösung gefunden der ähnliche Probleme hatte?

    Würde mich freuen.

    • Stefan
      Comment by Stefan:

      Hallo Ralph,

      wenn das Einbinden in die Domäne nach dem Einpflegen der Registry-Keys geklappt hat, sollte alles passen. Die Vermutung, Microsoft hat hier eine absichtliche Bremse eingebaut, halte ich für abwegig. MS hätte den Domain Join einfach komplett verweigern können (so wie ein Domain Join mit den „Home“-Versionen von Windows einfach nicht angeboten wird).
      Dass die Rechner dann langsam wurden, könnte vor allem an Deinen Gruppenrichtlinien (GPOs) liegen.
      Ein paar Ansatzpunkte: Werden die Rechner wieder schnell, wenn man sie aus der Domäne entfernt? Wenn ja, ist der Server schuld => GPOs und alle anderen Tasks überprüfen, die der Server den Clients aufzwingt (Desktop-Synchronisation?). Wenn nein, liegt das Problem wo anders => Taskmanager der Rechner checken!
      Gib Bescheid, ob das was geholfen hat!

      Gruß, Stefan

  34. Comment by Sara:

    Vielen, vielen Dank 🙂 Du hast mir eine längere Suche nach dem Fehler erspart.. Du kannst dir gar nicht vorstellen wie froh ich bin 😛

  35. Comment by Wolfgang:

    Vielen Dank, toller Tipp! Bei mir haben mehrere Rechner in meiner Windows 2008 R2 – Domäne plötzlich die Vertrauensstellung verloren und ließen sich mit der bekannten Fehlermeldung nicht mehr in die Domäne holen. Die Keys eingegeben, alles funktioniert wieder. Warum es vorher funktioniert hat, wird mir immer ein Rätsel bleiben.

  36. Comment by Lukas:

    Super – hat sofort geklappt. Vielen Dank.
    Gleiches Problem hatte ich mit Windows 2012 R2 DC und Windows 7 Ultimate. (Testumgebung auf VirtualBox)

  37. Comment by Farshad:

    vieeeeeeeeeeeeeeeeeeeeeeeeeeeeeelen Dank hat sofort klappt

Trackbacks / Pingbacks

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

CAPTCHA: Bitte folgende Rechenaufgabe lösen (blockiert Spam) - Ziffern eingeben! Danke! * Time limit is exhausted. Please reload CAPTCHA.